68844: Acronis Cyber Protect Cloud, Acronis Cyber Protect 15: Full backup of M1 Mac fails with "Backup is corrupted. Some data in the backup might be damaged because of hardware problems"

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Last update: 18-11-2022

Symptoms

Initial full backup of entire M1 Mac fails with "Backup is corrupted. Some data in the backup might be damaged because of hardware problems"

Error 0x4000d: The file is corrupted.

| trace level: warning
| line: 0x8af64b2c0920f7f0
| file: /Users/acronis/bs_hudson/workspace/ab-main-mac-installers/1713/product/core/resizer/archive3/archive3_error.cpp:178
| function: ConvertArchive3Error
| $module: disk_bundle_macarm64_26986
|
| error 0x29b138b: Data is corrupted: CRC mismatch or internal data structures mismatch
| line: 0x4c712998873fd8da
| file: /Users/acronis/bs_hudson/workspace/ab-main-mac-installers/1713/product/processor/backup/archive3_support.cpp:230
| function: operator()
| function: archive_close
| $module: disk_bundle_macarm64_26986

Cause

Issue in the product.

Solution

This issue has been fixed in Acronis Cyber Protect Cloud 21.08 (Agent build 27493), please update to the latest build.

To work around the issue without updating, disable decommit cache:

1. Navigate to /Library/Application Support/BackupClient/Acronis/sbin/. If there is no config file in /sbin, create the file.

2. Add this line to the file:
A3_DECOMMIT_SIZE=0

3. Save changes

4. Restart MMS service:

sudo launchctl stop acronis_mms
sudo launchctl start acronis_mms

 

5. Reattempt the backup