This article applies to:
- Acronis Cyber Protect 15
- Acronis Cyber Protect Cloud 9.0 and later versions
Issue
The installation of the Cyber Protect Agent fails with the following error message (from installation log):
Error 0x294000d: Socket bind error
| trace level: error
| line: 0x18073c0bca1ee95e
| file: d:\bs_hudson\workspace\mod-http\335\http\server\server_impl.cpp:806
| function: Http::Server::InstanceImpl::Run
| Address: 127.0.0.1
| Port: 43234
| $module: http_vsa64_335
Cause
The process of Acronis Managed Machine service cannot use port 43234 because another process is listening on this port.
Solution
Windows
To change the default port used by Acronis Managed Machine service in Windows OS:
- Stop Acronis Managed Machine service.
- Open the following file for editing, e.g with Notepad:
%programdata%\Acronis\Agent\var\aakore\mms.unit
- Set a new value for the port number in the following lines:
location: http://127.0.0.1:43234
port: 43234 - Save changes
- Start Acronis Managed Machine service
- Register the agent manually
Linux
To change the default port used by Acronis Managed Machine service in Linux OS:
- Stop Acronis Managed Machine service:
sudo service acronis_mms stop
- Open the following file for editing: /opt/acronis/var/aakore/mms.unit
- Set a new value for the port number in the following lines:
location: http://127.0.0.1:43234
port: 43234 - Save changes
- Start Acronis Managed Machine service:
sudo service acronis_mms start
- Register the agent manually