Replace the StructuredBackup.dll library with the one that has the fix to solve the issue
This article applies to:
Symptoms
- Using Acronis Recovery for Microsoft Exchange, you create a full backup of an information store;
- Then you run an incremental backup of the information store;
- The incremental backup task hangs at 100% and never succeeds;
- When you go to Task Manager on the Microsoft Exchange Server machine, you can see that the TaskService.exe process is consuming 0% of CPU.
The issue appears mostly when backup is saved to network.
Cause
This is a known issue with the product that has already been fixed.
Solution
- On the Microsoft Exchange Server machine invoke the Services window (Start-Run -> services.msc) and stop all Acronis services;
- Then invoke Windows Task Manager (Ctrl-Shift-Esc) and end the following processes:
- TaskService.exe
- agent.exe
- AcronisProgressServer.exe
- Browse to the following folder:
Windows 32 bit: \Program Files\Common Files\Acronis\DatabaseBackup\Fomatik\
Windows 64 bit: \Program Files (x86)\Common Files\Acronis\DatabaseBackup\Fomatik\and rename the StructuredBackup.dll file to StructuredBackup.dll.old;
- Download structuredbackup.zip and unpack it to same folder where you renamed the file;
- Invoke the Services window (Start-Run -> services.msc) and restart all Acronis services;
- Recreate the full backup and check if the issue remains for the incremental tasks.
More information
The downloaded StructuredBackup.dll library includes a fix for correct end-of-file placement and the task should not hang at 100% anymore.