Symptoms
You have changed a backup location but haven't made changes to the plans. Now you receive daily notifications about failed activities:
Activity failed
Activity 'Refreshing recovery points' failed. The credentials for location '//oldlocation' are not specified.
TROUBLESHOOT
In the protection plan, provide correct credentials for user '{{userName}}' and location '//oldlocation/'.
Cause
The backup location is removed, but its traces are left in DML databases and cache on the Agent side that triggers these notifications.
Solution
Acronis Cyber Protect Cloud: this issue has been fixed in Acronis Cyber Cloud 21.04.
Acronis Cyber Protect 15: this issue has been fixed in Update 2 (Build 26981). Please update to the latest build.
As a workaround for the previously deleted vaults, use this script:
- On the affected machine(s), download and unpack delete_backup_location.py.
- Open Command Prompt as an administrator.
- Use this command:
acropsh delete_backup_location.py - The script lists locations one by one and asks you for a confirmation to remove the location. Confirm removal of old locations, but keep (do not confirm) existing locations.