Symptoms
Installation of third-party endpoint security software (e.g. BitDefender Endpoint Security) fails or hangs on the machine where Acronis Agent is installed, even when Acronis Cyber Backup license is used or Antivirus & Antimalware protection is disabled.
Cause
Acronis Cyber Protect Agent and third-party endpoint security software use the same network filtering driver (bddci.sys) that cannot be shared.
Solution
Before installing third-party endpoint security software follow the steps below to remove bddci.sys driver:
- Disable Self-Protection on the machine:
- open the protection plan for editing,
- go to Active Protection module,
- turn off Self-protection,
- save and apply protection plan
- Open Elevated Command prompt: Start -> in search, type cmd -> right-click cmd.exe and select Run as administrator.
- Run the following commands:
sc stop bddci
sc delete bddci
- Install third-party endpoint protection software.
After uninstalling bddci.sys you would not be able to use Acronis URL Filtering feature. If later you would choose to use Acronis URL Filtering, then third-party endpoint security software should be uninstalled, and Acronis Cyber Protect Agent should be re-installed.
In the upcoming releases, Acronis Cyber Protect Agent would support the dynamic installation of components like bddci.sys, so the issues described in this article will be resolved automatically.