68043: Acronis Cyber Protect 15: Agent installation on 32-bit machine fails with "Failed to download installation file 'resource.xml' from the server."

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Last update: 23-09-2022

Symptoms

  1. Acronis Management Server is installed on a 64-bit machine
  2. When you attempt to add a device with 32-bit architecture, the installation fails with the following error:

     Installation process failed. {"Result":"Failed", "Code":"24510491", "Description":"Failed to download installation file 'resource.xml' from the server."}

Cause

32-bit remote installation files are not present on Management Server.

Acronis Development team is working on improving product behavior in situations when remote devices have 32-bit architecture.

Solution

  1. Download 32-bit installer:
    • Via account.acronis.com: login into your account, locate Acronis Cyber Protect 15 in the list of the products, click Go to Downloads and download Windows 32-bit full installer (for Acronis Cyber Protect  Subscription, click Download Acronis Cyber Backup -> Other download options, then download Windows 32-bit full installer)
    • Via backup console: in the backup console, click the account icon in the top-right corner > Downloads -> download Offline installer for Windows (32-bit)
  2. On Acronis Management Server navigate to C:\Program Files\Acronis\RemoteInstallationFiles\installation_files\<build_number> (e.g. C:\Program Files\Acronis\RemoteInstallationFiles\installation_files\15.0.25729 ), with x64 folder inside.
  3. Create a folder named "x86" inside the folder with build number (next to x64 folder):

  4. Run the Windows 32-bit full installer and click Create .mst and .msi files for unattended installation to extract the installation packagesExtract the .msi files (Management Server, Components for Remote Installation, Agent for Windows, Bootable Media Builder, Command-Line Tool, Acronis Cyber Protect 15 Monitor) from the 32-bit installer and place the extracted files in the x86 folder created at the previous step.
  5. Restart Acronis Service Manager service: go to Start -> Search -> type services.msc and press Enter. In Services window, locate Acronis Service Manager service and click Restart.
  6. Perform remote installation.

More information

For Acronis Cyber Backup 12.5, see Acronis Cyber Backup 12.5: Remote installation of 32-bit Agent from 64-bit Management Server.

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