67978: Acronis Cyber Protect Cloud Integration with ConnectWise Automate: Acronis plugin for ConnectWise Automate doesn't work with the latest Automate 2021.1 patch

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Last update: 18-11-2022

Symptoms

After update to the 2021.1 patch, you notice issues with ConnectWise integration:

Existing integrations are not appearing, however, they are available in the Automate database under the plugin_acronis_backup_partners table.

A new partner integration cannot be added. You get a connection error "Object reference not set to an instance of an object".

Client mapping is not working, however, the information about the companies is available in the database under the plugin_acronis_backup_companies table.

Acronis plugin logs cannot be collected.

Cause

Issue in the product. 

The root cause is that access permissions are not passed to all users, as a result, the plugin has no access to database tables and views.

The accounts and account data are not affected. Backup and protection services for endpoints continue working uninterrupted.

Solution

Acronis development team has resolved the issue.

The new Acronis plugin build 1.7.1155 is now available in ConnectWise Automate's Solution Center (Marketplace):
1. Partners should be advised to upgrade the Acronis plugin to the fixed 1.7.1155 hotfix build.
2. Restart of all Control Center instances and the LabTech Database Agent service after plugin upgrade is required.
* At Solution Center partners need to click on the Refresh Solution Info button on our plugin to see the new build.

If the issue persists with the latest build, please reach out to the support team with the following information:

  • Screenshot of the error message
  • Contents of the following folders from the Automate server:
  • C:\Program Files\LabTech\Logs
  • C:\ProgramData\LabTech Client\Logs
  • C:\ProgramData\Acronis\LabTech Plugin\Logs
  • Please specify whether the Automate server is hosted by ConnectWise or is on-premise