Symptoms
You have a Virtual Appliance and see a new update for it available under Settings -> Agents. You click Update, but there is no sign of VA being updated. Under Activities, you can see that the update task is in the Pending state.
Cause
Issue in the product. The issue reproduces in update sequences from 20.10 (build 24647) to later builds.
Solution
This issue was fixed in Acronis Cyber Protect Cloud 20.11.
If after starting the update, the update task is in the pending state for more than a minute, you need to manually reboot the VA.
To reboot VA for VMware: right-click the VA in the VMware Host Client inventory, select Guest OS from the drop-down menu, and select Restart.
To reboot VA for Virtuozzo Hybrid Infrastructure: click the VA in Virtuozzo Hybrid Infrastructure and click Reboot.
Retry update.