67084: Acronis Cyber Protect Cloud: Incorrect disk layout in Hyper-V VM after restore or instant restore from a disk-level backup or "Failed to get the ID of the boot disk" error

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Last update: 30-04-2021

Symptoms

You create a backup plan of a Hyper-V virtual machine using Agent for Hyper-V (agent on the host). In What to back up, you select Disks/volumes and then select individual disks or volumes you want to back up.

When recovering this VM or using the 'Running a virtual machine from a backup (Instant Restore)' feature, you encounter issues:

  • you notice that disk layout does not correspond with the original machine
  • restore/instant restore fails with this error:
    Error code: 26542128
    Fields: {"$module":"run_vm_from_image_vsa64_25851"}
    Message: Failed to get the ID of the boot disk.
    ------------------------
    Error code: 26542127
    Fields: {"$module":"run_vm_from_image_vsa64_25851"}
    Message: Operating systems are not found.

Cause

System reserved partition must be included in the backup, otherwise volumes logic is incomplete.

Solution

Use 'Entire machine' backup level: in What to back up, select Entire machine.

If you want to do a disk-level backup, add the system reserved partition to the backup or perform backup of the whole disk instead of the volume where OS is located. See this article for step-by-step guidance.

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