66502: DeviceLock DLP: "The older version of DeviceLock cannot be removed.(1714)" error when upgrading DeviceLock servers/consoles

use Google Translate

Applies to: 

Last update: Tue, 2020-11-17 09:53

Description

Upgrade of DeviceLock servers and consoles fails returning the "The older version of DeviceLock cannot be removed.(1714)" error.

Comments

This known issue is a problem of Windows Installer not related to DeviceLock directly.

Recommendations

Please search Microsoft Knowledge Base for information on this error and how to fix it.

Or follow these steps to resolve it:

  1. Uninstall your existing version of DeviceLock using "Programs & Features" menu (appwiz.cpl), then re-install DeviceLock.
  2. Run regedit, search for all "DeviceLock Service.msi" entries (without quotes), delete all such entries and, if DeviceLock Service.msi is included as list item, remove it from the list, then retry step 1.
  3. Run regedit, search for B6670558-7757-426E-AE44-65A1FA540EF0 entries, delete all of them and, if B6670558-7757-426E-AE44-65A1FA540EF0 is included as list item, remove it from the list, then retry step 1.