Update the product from the installation package or from the Acronis Management Console
This article applies to:
- Acronis Backup & Recovery 10 Advanced Server
- Acronis Backup & Recovery 10 Server for Windows (Standalone)
- Acronis Backup & Recovery 10 Advanced Server - Small Business Server Edition
- Acronis Backup & Recovery 10 Advanced Workstation
- Acronis Backup & Recovery 10 Workstation (Standalone)
- Acronis Backup & Recovery 10 Advanced Server - Virtual Edition
Symptoms
- You are attempting to update the Acronis Agent for Windows by executing the extracted MSI file - AcronisAgentWindows.msi;
- The operation fails with the following error message:
Another version of this product is already installed.
Installation of this version cannot continue. To
configure or remove the existing version of this product,
use Add/Remove Programs on the Control Panel.
Cause
In order for the MSI file to perform an update, the MSI file has to be launched with the re-install parameter. This is described in the section below.
Solutions
- Update the Acronis Agent by running the EXE installation package and clicking Update:
(!) You can download the main EXE package from your account, please see Downloading an Installation File of Acronis Software.
- If you have an advanced edition of the product, update the Acronis Agent(s) for Windows using the Remote installation wizard:
- Run Acronis Management Console;
- Select Install Acronis components:
- Proceed with the wizard.
- Additionally, the Acronis Agent can be updated by creating a transformation file and deploying the update via a Group policy. Please see the user guide for a detailed description.
More information
See also: