65653: Acronis Cyber Protect Cloud: Mailbox recovery fails with "Failed to connect to Microsoft Exchange API using url '{0}'"

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Last update: Wed, 2020-09-23 11:38

Symptoms

Customer attempts to recover an Exchange mailbox.

Recovery fails with the message similar to the following:

Cannot open public folder or mailbox <user@domain.com>

Access is denied.

Failed to connect to Microsoft Exchange API using url '{0}'

Cause

Incorrect Exchange configuration.

Acronis Cyber Backup uses the URL of Exchange Web Service (EWS) during recovery and gets this setting from Exchange.

To verify current setting in your environment: open Microsoft Exchange Management Shell and run the following request:
Get-WebServicesVirtualDirectory

Look at the Internal URL parameter in the output.

Internal URL is supposed to point to the internal URL of the CAS node in cluster, or to the Internal URL of the Exchange server if you have single node Exchange.

If this URL is wrong or points to an external URL, recovery will fail with errors specified above.

To work around this misconfiguration please use the solution below.

Solution

Configure URI to access EWS on current server:

1) Open Windows Registry Editor (regedit) on the Exchange machine and go to HKEY_LOCAL_MACHINE\Software\Acronis\BackupAndRecovery\ArxAgent\Settings\ 

2) Create a new String value with the name EwsUri and set the following as the value data:

3) Reattempt the recovery

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