65628: Acronis Cyber Protect Cloud: Recovery requires user interaction and shows 'Failed to read data from the disk' message

use Google Translate

Last update: Wed, 2020-08-26 12:41

Symptoms

File/folder recovery prompts for user interaction immediately upon start. You see this message: 

Failed to read data from the disk. 

If you click Ignore, recover fails with this error:

Error 0x1000d7: Failed to read the snapshot manager drive.
| trace level: error
| line: 0x8d5bf87c202e84eb
| file: d:\377\core\fdisk\disk_w.cpp:144
| function: disk_w::OpInt
| $module: disk_bundle_vsa64_23094
|
| error 0x9: Unknown status.
| line: 0x2aacb7b2ab852ac
| file: d:\377\core\fdisk\ver2\arch\windows\win_errors.cpp:40
| function: Fdisk::AddKstatusError
| code: 0x5
| $module: disk_bundle_vsa64_23094
|
| error 0xfff0: Access is denied
| line: 0xbd28fdbd64edb8f8
| file: d:\377\core\common\error.cpp:314
| function: Common::Error::AddWindowsError
| code: 0x80070005
| $module: disk_bundle_vsa64_23094

Cause

There is a disk attached to this machine that cannot be read. This should not necessarily be the target disk for recovery; by design, Acronis SnapAPI/fdisk-related components try to list all disks detected in the machine by reading their first sectors. 

If an attached disk has access restrictions (for example, is password-protected or requires unlocking the drive with a vendor utility) Acronis SnapAPI cannot enumerate the disk and will prompt for user interaction.

Solution

Make sure all drives are accessible or temporary detach the drive with access restrictions, and then perform recovery.