65599: Acronis Cyber Protect Cloud: Agent installtion or registration fails with "error 0x2260006: Could not resolve host: localhost"

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Last update: Mon, 2020-08-24 18:17

Symptoms

Installation or manual Agent registration fails. In installation logs (for Linux and Mac) or bootstrap.log (for Windows), you see an error similar to this:

Error 0x2470001: HTTP transfer error
| line: 0xcbd0886296318957
| file: /Users/hudson_agent/bs_hudson/workspace/ABR-acp9.0-agents-mac-installers/293/product/enterprise/common/http/curl_transport.cpp:418
| function: MakeError
| requestType: POST
| uri: localhost/api/mms/registration
| host: localhost
| port: 0xa8e2
| curlResult: 0x6
| $module: register_agent_macia64_22750
|
| error 0x2260006: Could not resolve host: localhost
| line: 0xcbd0886296318956
| file: /Users/hudson_agent/bs_hudson/workspace/ABR-acp9.0-agents-mac-installers/293/product/enterprise/common/http/curl_transport.cpp:417
| function: MakeError
| $module: register_agent_macia64_22750

Cause

localhost can't be resolved into proper loopback IP address (127.0.0.1)

Solution

Solution varies depending on the issue, but the issue is often environmental.

Start investigating the issue by running this command in the Command Prompt or Terminal:

ping localhost

Normally, the output should contain "::1" (for IPv6) or "127.0.0.1" (for IPv4), which indicates that localhost is resolved correctly. 

If it doesn't, you need to look deeper into your network settings. The issue could be caused by incorrect records in /etc/hosts or C:\Windows\system32\drivers\etc\hosts, wrong network settings, etc.

If it does, collect Acronis system information and contact Acronis support.