65437: Acronis Cyber Protect Cloud: Cannot save plan with large number of "Items to back up"

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Last update: 03-08-2021

Symptoms

Impossible to create or save file backup plan with excessive amount of selected items.

Issue occurs in one of the following scenarios:

  1. You start to create file-level backup plan.
  2. You select a large number of files/folders, e.g. 1000 files (there is no fixed number)
  3. When you try to save the plan, it is not saved:

OR

1. You create or edit a protection plan.

2. In Data to backup choose Select items directly, you select a folder with a lot of subfolders/files inside, then deselect some of the subfolders/files.

3. When you click Save or Create, the protection plan loads and is not saved. No error message is shown.

Cause

Issue in the product. The issue will be fixed in next releases of Acronis products.

When one folder is selected for backup, the program considers it as 1 source, even if the folder contains a large amount of files/subfolders. If some files/subfolders in the folder are de-selected, Agent selects all other contents of this folder implicitly, resulting in a large number of backup sources, which causes this issue.

Solution

Consider adjusting your backup strategy. You can:

  • select fewer items
  • select the folder instead of drilling down to folder contents
  • or split your data to protect into several backup plans (for example, protect a lesser amount of files with one file-level backup plan while protecting other files with a folder-level or disk-level plan)
  • use inclusion or exclusion rules instead of manually selecting or deselecting items with similar extensions, locations, name patterns

According to performed tests, the maximum amount of items that can be selected depends on path length (short file path allows to have more items selected). The average amount of selected items should not exceed 800.

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