65399: Acronis Cyber Backup 12.5, Acronis Cyber Protect Cloud: Files are 0 Bytes after download if they have reparse points attribute

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Operating Systems: 

Symptoms

  1.  You recover a file from a backup using Download option, but after download the recovered file is 0 bytes in size;
  2. In mms log (C:\ProgramData\Acronis\BackupAndRecovery\MMS\mms.0.log), there are warnings about "Unsupported file type"

Failed to add file ''D:/File Storage/test_file.pdf' to archive.
| trace level: warning
| line: 0x491fba4e04c6751
| file: e:\99\products\velight\agent\compressed_stream_registry\impl\archive_stream.cpp:89
| function: `anonymous-namespace'::ArchiveStream::DownloadProc
| $module: disk_bundle_vsa64_9010
|
| error 0x40021: Unsupported file type.
| line: 0x491fba4e04c6752
| file: e:\99\products\velight\agent\compressed_stream_registry\impl\archive_stream.cpp:90
| function: `anonymous-namespace'::ArchiveStream::DownloadProc
| $module: disk_bundle_vsa64_9010

Cause

Most probable cause for this behavior is that files that you are trying to restore have a REPARSE_POINT attribute. Due to current limitation of NTFS file driver Acronis Backup cannot recover such files via web interface.

Reparse points are objects in the NTFS file system, there is an attribute defined by user-specified data and they are used to extend functionality in the input / output subsystem (I / O)

To check that the file has REPARSE_POINT attribute, check the original file (if it is available) by running the following command in Command Prompt:

fsutil reparsepoint query <path_to_file>

e.g. fsutil reparsepont query "D:\documents\example.pdf"

If the file or folder contains a reparse point, output will return the reparse point attributes:

If the file does not have a reparse point, the command will return an error:

If the original file  is not a reparse point, then the root cause is different and the issue needs to be investigated separately

Solution

As a workaround, instead of recovering files via web interface, mount the backup archive via File Explorer and copy the necessary files from it: 

  1. Browse to the backup location by using File Explorer.
  2. Double-click the backup file. By default, the file names are based on the following template:

    <machine name> - <backup plan GUID>

  3. If the backup is encrypted, enter the encryption password. Otherwise, skip this step.
  4. File Explorer displays the recovery points.
  5. Right-click a volume to mount, and then click Mount
  6. If the backup is stored on a network share, provide access credentials. Otherwise, skip this step.
  7. The software mounts the selected volume. The first unused letter is assigned to the volume.
  8. Browse the mounted volume and copy the files that you want to restore.

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