65396: Acronis Cyber Protect Cloud: Date is one day behind in reports related to Activities

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Symptoms

If timezone is UTC -*, (such as UTC/GMT -5 hours), then date in all Protection Console's reports related to activities is one day behind the date when the activity happened.

If activity reports are scheduled, they also arrive with incorrect date which is one day behind the real date.

Cause

Issue in the product.

The behavior is observed when the viewer's machine has a negative timezone offset (like GMT-5). Due to grouping requirements, the backend returns the "date" field with a pre-applied timezone offset.
The UI applies timezone offset (-5 hours) one extra time and the user sees the previous day. This issue affects not just the Activity list, but also Active Alerts list and Alerts history.

Solution

There is no solution or workaround at the moment.

This issue will be fixed in one of the upcoming updates of Acronis Cyber Cloud.

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