Symptoms
You have a machine with a local DNS server (such as unbound or named) in a network with DHCP.
Recovery (entire machine or disk-level that requires reboot) fails with this error:
{"domain":"Access","code":"InvalidGrant","debug":{"msg":"couldn't get upstream token, Post https://jp-cloud.acronis.com/bc/idp/token: dial tcp: lookup jp-cloud.acronis.com on 127.0.0.1:53: read udp 127.0.0.1:55705-\u003e127.0.0.1:53: read: connection refused"},"error":"invalid_grant","error_description":"couldn't get upstream token, Post https://jp-cloud.acronis.com/bc/idp/token: dial tcp: lookup jp-cloud.acronis.com on 127.0.0.1:53: read udp 127.0.0.1:55705-\u003e127.0.0.1:53: read: connection refused"}
Or:
{"domain":"Access","code":"InvalidGrant","debug":{"msg":"couldn't get upstream token, Post https://jp-cloud.acronis.com/bc/idp/token: dial tcp: lookup jp-cloud.acronis.com on [::1]:53: dial udp [::1]:53: socket: address family not supported by protocol"},"error":"invalid_grant","error_description":"couldn't get upstream token, Post https://jp-cloud.acronis.com/bc/idp/token: dial tcp: lookup jp-cloud.acronis.com on [::1]:53: dial udp [::1]:53: socket: address family not supported by protocol"}
Cause
DHCP server forwards requests to the localhost DNS server which processes these requests in live operating system. During recovery, the machine is booted into Acronis environment and can no longer use the local DNS server, which causes this connection issue.
Solution
- Install update 20.07 (see Acronis Cyber Protect Cloud: how to update to the latest build).
- In /etc/Acronis/, create a file named resolv.conf
- In this file specify DNS settings used by the DNS server on this machine.
Now settings from this file will be used during recovery with reboot.