Symptoms
- You back up a Hyper-V Gen2 VM using Agent for Windows installed inside VM;
(!) This issue does not reproduce with agentless backup
- After you recover this backup as new VM via Agent for Hyper-V, restored VM does not boot properly: only black screen appears. When you check properties of the restored VM in Hyper-V, restored VM is Gen1.
Cause
Specifics of product implementation.
When a Hyper-V VM is backed up using an agent inside guest OS rather than via agentless backup, Acronis Cyber Backup has no information about VM generation and so the VM is automatically recovered as Generation 1.
Acronis plans to introduce the ability to specify VM generation during recovery in future versions of the product.
Solution
To work around this issue, create a new Gen2 VM on Hyper-V host, boot this VM from Acronis Bootable Media (see Acronis Cyber Backup 12.5: how to create a bootable media) and perform recovery using bootable media: see product documentation for instructions.