65174: Acronis Cyber Infrastructure: Impossible to update cluster due to missing 'Install' button

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Last update: 15-10-2021

Symptoms

1. On multi-node Acronis Cyber Infrastructure cluster after downloading updates via WebCP > Settings > Updates > Download there is no Install button:

2. Manual check of update status via CLI shows that one of the nodes has status uptodate while another ones are in download_completed status:

[root@node01 ~]# vinfra software-updates status | egrep 'host:|status'
|                           |   host: node01.vstoragedomain            |
|                           |   status: download_completed             |
|                           |   host: node02.vstoragedomain            |
|                           |   status: download_completed             |
|                           |   host: node03.vstoragedomain            |
|                           |   status: download_completed             |
|                           |   host: node04.vstoragedomain            |
|                           |   status: uptodate                       |
| status                    | available                                |

3. Node with uptodate status was recently installed from the scratch and added to the cluster having the latest available version installed, 3.5.4 (24) in this example:

[root@node04 ~]# cat /etc/hci-release
Acronis Cyber Infrastructure 3.5.4 (24)

Cause

Issue in the product.

Solution

The issue has been fixed in version 4.0.

As a workaround, it is possible to start cluster update manually via CLI:

[root@node01 ~]# vinfra software-updates start

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