65082: Acronis Cyber Protect Cloud: backup on macOS fails with "Resource deadlock avoided" or "Bad file descriptor"

use Google Translate

Operating Systems: 

Last update: Tue, 2020-09-29 07:50

Symptoms

You are backing-up macOS machine and backup fails with:

Error code: 43716607
Fields: {"$module":"disk_bundle_macia64_22530","function":"file_backup_run","path":"/1/<archive_name>.tibx"}
Message: Unknown error
------------------------
Error code: 65521
Fields: {"$module":"disk_bundle_macia64_22530","code":11,"function":"read","path":"/Users/<username>/Library/Mobile Documents.<XXXXXX>/*.*"}
Message: Resource deadlock avoided

------------------------

or

Error code: 43712518
Fields: {"$module":"disk_bundle_macia64_22530","function":"file_backup_run","path":"/1/<archive_name>.tibx"}
Message: Misc error while local file io
------------------------
Error code: 65521
Fields: {"$module":"disk_bundle_macia64_22530","code":9,"function":"read","path":"/Users/<username>/Library/Mobile Documents..<XXXXXX>/*.*"}
Message: Bad file descriptor
------------------------

Cause

The folder /Users/[username]Library/Mobile Documents.<XXXXXX> is the folder for iCloud files on Mac. These files are stored on the cloud rather than on the local machine.

 Solution

This issue has been fixed in Acronis Cyber Protect Cloud 20.09 Build 24476: this folder is added to default exclusions.

As a workaround for earlier builds, exclude this path from backup:

Go to  'File filters' option > 'Do not back up files matching the following criteria':

/Users/<username>/Library/Mobile Documents.<XXXXXXX>/*.*

 

Tags: