64771: Acronis Cyber Protect Cloud: how to change port 9999

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Last update: Fri, 2020-08-07 16:30

Symptoms

During Agent registration, you receive this error:

Couldn’t connect to host.

In aakore logs, you find this error:
"msg":"tcp bind error: listen tcp 127.0.0.1:9999: bind: address already in use"

Cause

Starting with version 9.0, local port 9999 is required to be open for inbound connections. This port is required for communication between agent and management components.

The error indicates that port 9999 is already used by another software, most probably by Oracle HTTP server (port 9999 being one of one of two default SOAP server ports for Oracle HTTP server).

You can check which software uses the port:

In Windows:

  1. Run:
    netstat -ano | findstr 9999
    to find the PID of the process listening on 9999
  2. Run:
    tasklist /svc /fi "pid eq <PID>"
    where <PID> is the process ID found in step 1.

In Linux:

  1. Run:
    netstat -ant | grep 9999
    to find the PID of the process listening on 9999
  2. Run:
    ps -p <PID> -o comm=
    where <PID> is the process ID found in step 1.

Solution

In Acronis Cyber Cloud 9.0 Update 2 (Build 22750) and later versions,  Acronis Agent Core Service (aakore) uses a dynamic port by default.

For earlier versions, you can change port 9999 in Acronis configuration:

1. On the affected machine, navigate to:

  • Windows C:\ProgramData\Acronis\Agent\etc\
  • Linux /opt/acronis/etc/

2. Open aakore.yaml. For example, with Notepad.

3. In this line, change port 9999 to another port that is not currently in use:
http: 127.0.0.1:9999

4. Restart aakore service