64741: Acronis Cyber Protect Cloud: update may fail on Win7, 8, 8.1 in case Microsoft Visual C++ Redistributable runtime is not installed

use Google Translate

Symptoms

You want to update Acronis Agents to version 9.0. In Settings -> Agents you select the agent and click Update agent.

You notice these symptoms: 

  • “No C++ runtime installed, install manually first” in the console
  • Alert stating that a planned activity was not completed
  • Cyber Protect services don't work
  • Windows Defender is not disabled

Cause

Cyber Protect services require Microsoft Visual C++ 2017 Redistributable runtime packages to be installed on the device. Acronis installation package installs them during manual installation. However, update initiated from the service console requires these packages to be previously installed.

Solution

Install Microsoft Visual C++ 2017 on the affected machine and then re-attempt update.