Symptoms
After Agent update, backup or another operation (e.g. replication, recovery) fails with one of the following errors:
{"domain":"Access","code":"InvalidGrant","debug":{"msg":"couldn't get upstream token, failed to get upstream token provider"},"error":"invalid_grant","error_description":"couldn't get upstream token, failed to get upstream token provider"}
or
"Request to the cloud platform failed because the agent is not registered"
Additionally, check installation logs in C:\ProgramData\Acronis\InstallationLogs (or in InstallationLogs folder in System Report).
In Installation logs you can find messages similar to:
Error 0x2470001: HTTP transfer error
| line: 0xcbd0886296318957
| file: e:\164\enterprise\common\http\curl_transport.cpp:418
| function: Http::Curl::CurlDetails::RequestScope::MakeError
| requestType: POST
| uri: localhost/api/mms/registration
| host: localhost
| port: 0xa8e2
| curlResult: 0x7
| $module: register_agent_vsa64_21670
|
| error 0x2260007: Failed to connect to localhost port 43234: Connection refused
| line: 0xcbd0886296318956
| file: e:\164\enterprise\common\http\curl_transport.cpp:417
| function: Http::Curl::CurlDetails::RequestScope::MakeError
| $module: register_agent_vsa64_21670
Cause
Problem happens if mms service experiences long start time (eg. 5 minutes) after upgrade to new agent. As s result attempt of agent registration fails and it remains unregistered and cannot obtain the necessary service role.
Solution
Register the agent manually as described in Registering Backup Client Manually.