Symptoms
Backup fails sporadically due to service_process.exe crash
Error message in log details:
TOL: Process 'service_process.exe' has failed.
Cause
Service_process.exe crashes due to access violation exception when interacting with OS network calls.
Solution
On the machine where Agent is installed, replace logging.dll libraries with custom libraries containing a fix:
1) Download logging.zip
2) Stop all Acronis services
3) In the following folders, rename logging.dll to logging.dll.old
- C:\Program Files (x86)\Common Files\Acronis\BackupAndRecovery\Common
- C:\Program Files (x86)\Common Files\Acronis\BackupAndRecovery\Common64
4) Copy the .dll files from the archive:
Place logging.dll from vs folder to C:\Program Files (x86)\Common Files\Acronis\BackupAndRecovery\Common
Place logging.dll from vsa64 to C:\Program Files (x86)\Common Files\Acronis\BackupAndRecovery\Common64
5) Start all Acronis services