Symptoms
You want to delete backups from cloud storage. Operation fails with this error message:
Error code: 219
Module: 161
LineInfo: 0x0B320396ADFE3D39
Fields: {"IsReturnCode":"1","$module":"disk_bundle_vsa64_******"}
Message: Failed to delete the archives.
------------------------
Error code: 7
Module: 4
LineInfo: 0x60CCAC0523AC0F48
Fields: {"Name":"ARCHIVE_NAME.tibx","$module":"archive3_adapter_vsa64_******","PcsCode":"36"}
Message: Error occurred while opening the file.
------------------------
Error code: 12
Module: 4
LineInfo: 0xC8D8731CE106FA29
Fields: {"$module":"archive3_adapter_vsa64_*******"}
Message: The file is read-only.
Cause
Cloud Storage quota was set to 0 or Cloud Backup offering item was disabled.
Disabling quota or offering item makes Agent's cloud certificate read-only. With a read-only certificate, retention jobs cannot be performed, thus deleting archive(s) failed.
Solution
Use one of these methods:
- Logged as corresponding backup user, delete archive(s) in Web Restore Console.
- Or temporary increase cloud storage quota and delete backups:
- In account management panel, increase the Cloud Storage quota and wait up to 10 min.
- Switch to Cyber Protection console by clicking Manage service.
- To renew the cloud certificate, run backup to cloud on any machine (it can be canceled once it's at least >5% of progress).
- Navigate to the Backup storage tab. Select the backups you want to delete and select the machine from previous step in the Machine to browse from: list.
- Delete archives while browsing it from that device/Agent.