Symptoms
1. You have a Hyper-V host with Virtual Desktop Infrastructure role;
2. You install Acronis Agent for Hyper-V;
3. When you try to create a new automatic collection, creation fails with
Could not retrieve the virtual desktop template details for <VM_Name>
Cause
SAN policy is set to Offline All during Agent for Hyper-V installation. This change is necessary to prevent Windows from breaking the bootability of the VMs recovered and/or converted from backups by Agent for Hyper-V.
If SAN policy is not set to Offline All, then tasks for VM recovery/VM conversion may produce warnings and unbootable VMs due to automatic mounting of the virtual disks performed by Windows which adds changes to partitions structure.
Solution
In order to create a collection in VDI, change SAN policy to Offline Shared:
- On Hyper-V host, Log on as an administrator, open the command prompt, type diskpart, and then press Enter.
- Type san, and then press Enter. Ensure that SAN Policy : Offline All is displayed.
- Type san policy=offlineShared and press Enter.
- Restart the machine.
It is recommended to change SAN policy back to Offline All (san policy=offlineall) after collection creation, to avoid warnings related to VM recovery/conversion.