62906: Acronis Cyber Cloud: Cannot connect to Acronis Cloud from CloudBlue integration with "SSL connect error"

use Google Translate

Applies to: 

Symptoms

  • APS package is installed on CentOS 6.x
  • When trying to connect to the Acronis Cloud from the APS endpoint, the following errors appear in /var/www/html/backupservice/log/Events

2019/04/30 10:54:17 5cc829584d633 Error Request error: SSL connect error File:'/var/www/html/backupservice/tenantBase.php' Line:'602'
2019/04/30 10:54:17 5cc829584d633 Information --debug Request GET to https://eu-cloud.acronis.com/api/1/groups/348678/users/ request body: () File:'/var/www/html/backupservice/app/Service/BaseClient/RestTransport.php' Line:'117'
2019/04/30 10:54:17 5cc829584d633 Error --debug Response GET from https://eu-cloud.acronis.com/api/1/groups/348678/users/ error Request error: SSL connect error File:'/var/www/html/backupservice/app/Service/BaseClient/RestTransport.php' Line:'143'
2019/04/30 10:54:17 5cc829584d633 Warning Connection error:Request error: SSL connect error File:'/var/www/html/backupservice/app/Service/MspApiClient/Api.php' Line:'694'
2019/04/30 10:54:17 5cc829584d633 Information --debug Request POST to https://eu-cloud.acronis.com/api/1/login/ request body: ({"password":"*****","username":user@server"}) File:'/var/www/html/backupservice/app/Service/BaseClient/RestTransport.php' Line:'117'
2019/04/30 10:54:17 5cc829584d633 Error --debug Response POST from https://eu-cloud.acronis.com/api/1/login/ error Request error: SSL connect error File:'/var/www/html/backupservice/app/Service/BaseClient/RestTransport.php' Line:'143'

 

  • The following records appear in /var/log/pa/core.log file on Management Node when reproducing the issue: 

Apr 30 12:50:06.286 : DBG [aps-service:9027560 aps-service-task-149:956 pau]: c.p.p.s.a.ExceptionHandlerServlet error response body={"error":"Service_BaseClient_IOException","message":"35: Request error: SSL connect error","code":35,"error":"Service_BaseClient_IOException","message":"35: Request error: SSL connect error","packageId":"cf0d0550-163e-450c-a7f0-70199485b847","http_request":"GET https://eu-cloud.acronis.com/api/1/login/"}, exception=com.parallels.pa.service.aps.api.APSEndpointExecutionException: 35: Request error: SSL connect error 

Cause

For security reasons, earlier versions of SSL\TLS protocols were prohibited in Acronis Cyber Cloud 7.9. Only TLS v1.1 and TLS v1.2 are supported. 

The fact that TLS v1.0 was disabled by Acronis Cyber Cloud 7.9 deployment in the datacenters causes this error.

Solution

To resolve the issue please update libcurl to the latest version.

If updating libcurl is not possible, please contact Acronis Customer Central with reference to this article.

Tags: 

You are reporting a typo in the following text:
Simply click the "Send typo report" button to complete the report. You can also include a comment.
CAPTCHA
This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.
5 + 5 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.