62901: Acronis Cyber Protect Cloud: Agent installation on Domain Controller fails with LocalGroupAdd errors

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Last update: Wed, 2020-04-15 10:54

Symptoms

You are installing Acronis Agent on a Domain Controller. Installation fails.

When checking MSI installation log, you see this error:

1: [14:47:49:595]: InstallGroups: InstallGroup::Execute: CADataOutputTraced::GetProperty: propertyName = Acronis Remote Users_WillBeInstalled, value = 1 
1: [14:47:49:595]: InstallGroups: InstallGroup::Execute: Creating group. 
1: [14:47:49:595]: InstallGroups: InstallGroup::Execute: CADataOutputTraced::GetProperty: propertyName = Acronis Remote Users_Description, value = Members are allowed to remotely connect to the machine by using console. 
1: [14:47:49:689]: InstallGroups: an error has been thrown: 

Error 0x140bb8 
| line: 0x8e9561535b69d7c3 
| file: e:\354\core\winex\user_iterator.cpp:384 
| function: Windows::LocalGroupAdd 
| $module: custom_actions_msp_vsa64_s_12960 

CustomAction InstallGroups returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox) 
MSI (s) (B8:AC) [14:47:49:751]: User policy value 'DisableRollback' is 0 
 

Cause

The issue appears because the list of Domain Controllers contains a DC which does not exist anymore. This prevents Acronis Agent installer from creating groups on DC level.

Solution

1. List of domain controllers can be obtained by running command in the Command Prompt:
 netdom query DC

2. Remove the non-existent DC from the list of Domain Controllers in Active Directory and reattempt Acronis Agent installation.

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