Symptoms
- You save backups to an unmanaged location using Version 12 archive format
- Two or more backup archives have the same "Date modified" value
Cause
This behavior is by design and it is due to the way retention rules work in the Version 12 archive. Several archives have the same "Date modified" because Agent performs checks of previous backup slices to apply retention policy within backup plan.
To find out the correct creation date, add column "Date Created" in the Windows Explorer: select View tab, click Add columns and select Date created (this column is usually not shown in default view)