62675: Acronis Cyber Backup 12.5: Management Server update fails with "Create database permission denied"

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Last update: 31-05-2021

Symptoms

  1. Your Acronis Management Server database is stored in external SQL server (not the built-in SQLite)
  2. You launch installation of Acronis Cyber Backup 12.5 Build 12730 (or later) to update existing Acronis Management Server. 
  3. Update fails
  4. Installation log contains the following message:

    1: Error 0x1290021: 42000: [Microsoft][ODBC SQL Server Driver][SQL Server]CREATE DATABASE permission denied in database 'master'
    | line: 0x73e0fa028b14928f
    | file: e:\348\enterprise\common\db\mssql\odbc.cpp:207
    | function: Data::MsSQL::OdbcConnection::ExecuteStatement::<lambda_fe3e0aed80a59a419f0aaa72b8e8dbd1>::operator ()
    | $module: custom_actions_ab_vsa64_s_12890 
    CustomAction MsiManagementServerServiceInstallInstall_ManagementServer_II returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (1C:78) [03:07:48:034]: Note: 1: 2265 2:  3: -2147287035 
    MSI (s) (1C:78) [03:07:48:034]: User policy value 'DisableRollback' is 0
    MSI (s) (1C:78) [03:07:48:034]: Machine policy value 'DisableRollback' is 0
    Action ended 3:07:48: InstallFinalize. Return value 3.

Starting from build 13160, installer automatically verifies the necessary rights and shows appropriate message in the installer:

Account "domain\user" does not have enough permissions to create databases in SQL Server instance "Server\Instance". Add the specified account to the 'dbcreator' or 'sysadmin' fixed server-role in the SQL server

Cause

Acronis Management Server Service user does not have enough rights to create new SQL databases. For successful installation, AMS_user should have admin privileges on SQL server.

Solution

Grant 'sysadmin' or 'dbcreator' role to the AMS_User and retry the product update.

Scenario 1

  1. Go to Start -> Run -> Ssms.exe (run as Administrator).
  2. Choose the server with Acronis instance and click on “Connect”.
  3. Go to Security -> Expand Logins -> double-click on the AMS_user -> Go to Server Roles section and place a check mark on "sysadmin" (and/or "dbcreator") role to add this role to the user.
  4. Click on “OK”, close the console and install the update.

Scenario 2

(if the previous Scenario fail with error – you do not have rights to save the changes or you have no installed SQL Management Studio; instructions are provided for granting 'sysadmin' role, to provide 'dbcreator' role adjust accordingly)

  1. Create on the desktop a .txt file with following T-SQL-script in it:
    Exec master..sp_addsrvrolemember @loginame = 'DOMAIN\AMS_user',@rolename = 'sysadmin'
    (where DOMAIN\AMS_user is the user to which you want to grant the sysadmin role)
  2. Go to Start-> Run- >services.msc
  3. Find the service SQL Server (<AMS_instance>) (where "AMS_instance" is the name of the instance used for Acronis Management Server database) and stop the service. Stop Acronis Management Server Service as well.
  4. Go to Start -> Run -> cmd as Administrator
  5. Type in net start MSSQL$<AMS_instance> /m,
    where "AMS_instance" is the name of the instance used for Acronis Management Server database, e.g. net start MSSQL$Instance1 /m
  6. Type in the following command after
    sqlcmd -S <machine name>\<AMS_instance> -i <full path to the SQL script created in step 1>
    where "AMS_instance" is the name of the instance used for Acronis Management Server database, e.g. sqlcmd -S TestPC\Instance1 -i C:\scripts\tsqlscript.txt
  7. Close the cmd window after the script worked (the should be no output), restart SQL Server (AMS_instance), start Acronis Management Server Service.
  8. Start the installation file under Administrator and install the update

 

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