62659: Acronis Data Cloud: downgrading APS package

use Google Translate

Applies to: 

Overview

When running an upgrade of APS package for Acronis Data Cloud, installation procedure fails and it is impossible to proceed with the upgrade procedure after eliminating the root cause.

In this case, you will need to downgrade the APS package following the instruction below, and reach out to Acronis support for further assistance.

Limitations

Downgrade should not be performed in following cases:

  • You are installing a minor update (hotfix, e.g. 2.0.1>2.0.2).
  • You are running a multi-instance installation, and some of the instances already upgraded to a newer version.

Solution

1. Log in to APS endpoint.

2. Find the name of the current RPM: 

rpm -qa | grep acronis

acronis-data-cloud-2.2-2007.el7.centos.noarch

3. Remove the RPM:

rpm -e acronis-data-cloud-2.2-2007.el7.centos.noarch

4. Install the previous version according to Deployment guide.

Notes:

  • The previous version number must be the same as your current application instance is.
  • Odin returns an expected message while installing previous version. Ignore this message. Example:

Exception: The are no available packages of application with id 125 with version greater than '2.0-2052' for upgrade of application instance. warning: %post(acronis-data-cloud-2.0-2052.el7.centos.noarch) scriptlet failed, exit status 1

Tags: 

You are reporting a typo in the following text:
Simply click the "Send typo report" button to complete the report. You can also include a comment.
CAPTCHA
This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.
2 + 8 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.