62569: Acronis Backup: device does not appear in backup management console after installation

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Symptoms

You have installed Acronis Agent and registered it in your account, but when you open the backup management console, this device is not listed in Devices.

In mms log on the affected machine (located in C:\ProgramData\Acronis\BackupAndRecovery\MMS\), you see this error:

| error 0x1403f4: WMI 'ExecQuery' failed for query '%ls'.
| line: 0xc523d9a02d03d55c
| file: e:\310\core\winex\wmi_acc.cpp:305
| function: Windows::WMIClass::Select
| Query: SELECT * FROM Win32_OperatingSystem
| $module: mms_vs_12420

Cause

WMI is Windows Management Instrumentation, Acronis uses its functionality on Windows machines to get information about disks, system and services.

The error indicates that Acronis Agent had attempted a query via WMI tools and WMI tools failed to process it.

This is often caused by WMI repository issues in the Windows OS.

Solution

Diagnosis of WMI can be performed with a special Windows utility:

The WMI Diagnosis Utility

A general article on WMI troubleshooting:  Microsoft Technet: WMI isn't working.

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