62398: Acronis Cyber Protect Cloud: CloudBlue subscription synchronization fails, usage is not updated

use Google Translate

Last update: 18-11-2022

Applicable to:

  • Acronis Cyber Protect Cloud APS package 2.0

Sympthoms

CloudBlue Synchronize task fails with error message similar to:

Could not get resource usage for resource with UUID 'e3ebcc15-9387-476d-baed-e59ae779ef1f': Not Found: Aggregated usages from datacenter "a4f19d27-4c24-41ab-91ff-3485fbe2b861" are not found for date "2019-01-15".

404 Not Found

Body: com.parallels.pa.service.aps.api.APSEndpointExecutionException: Not Found: Aggregated usages from datacenter "a4f19d27-4c24-41ab-91ff-3485fbe2b861" are not found for date "2019-01-15". Could not get resource usage for resource with UUID 'e3ebcc15-9387-476d-baed-e59ae779ef1f': Not Found: Aggregated usages from datacenter "a4f19d27-4c24-41ab-91ff-3485fbe2b861" are not found for date "2019-01-15".

404 Not Found

Body: com.parallels.pa.service.aps.api.APSEndpointExecutionException: Not Found: Aggregated usages from datacenter "a4f19d27-4c24-41ab-91ff-3485fbe2b861" are not found for date "2019-01-15".

_____JobManager_____0

 

As a result, 5 or less subscriptions show incorrect resource usage.

Cause

Issues with Acronis Cyber Protect Cloud reports:

  1. Acronis Cyber Protect Cloud failed to generate usage report.
  2. Data in generated report is invalid.
  3. Tenant mentioned in usage report was deleted in manually in Acronis Cyber Protect Cloud.

Incorrect CloudBlue settings:

  • Synchronize task was was executed before usage report was downloaded from Acronis Cyber Protect Cloud. A CRON job is downloading usage report from Acronis Cyber Protect Cloud every hour. After report is downloaded, synchronize task is able to retrieve usage.

Incorrect endpoint configuration:

  • Redis server is not running.
  • CRON job on endpoint has been dropped or modified.

Solution

Issues with Acronis Cyber Protect Cloud reports:

Contact support

Incorrect CloudBlue settings:

Set up Sinchronize task schedule according to CRON job configuration.

Incorrect endpoint configuration:

Check that endpoint settings are correct:

  • Verify that Redis is running:

    systemctl status Redis

  • Verify that CRON job exists and has proper schedule.

More information

CloudBlue Synchronize tasks process subscriptions in a bulk. Default number of subscriptions in one task is 5.

To modify number of processed subscriptions, contact CloudBlue support at https://www.cloudblue.com/support/.

CloudBlue reference ticket numbers: POA-111909, CR-1628.

Tags: