62369: Acronis Cyber Protect: VSS writer has failed to process the snapshot

    Last update: 01-03-2023

    Symptoms

    Backup with activated Volume Shadow Copy fails with the following error similar:

    The backup has failed because 'VSS Writer' has failed during snapshot creation.

    This error can be produced by different VSS writers, see some examples below:

    • VSS writer 'System Writer' with class ID 'E8132975-6F93-4464-A53E-1050253AE220' has failed to process the snapshot
    • VSS writer 'ASRWriter' with class ID 'BE000CBE-11FE-4426-9C58-531AA6355FC4' has failed to process the snapshot
    • VSS writer 'SqlServerWriter' with class ID 'A65FAA63-5EA8-4EBC-9DBD-A0C4DB26912A' has failed to process the snapshot. 
    • VSS writer 'Registry Writer' with class ID AFBAB4A2-367D-4D15-A586-71DBB18F8485'' has failed to process the snapshot
    • VSS writer 'Virtuozzo VSS Writer' with class ID '5AFFB034-969F-4919-8875-88F830D0EF89' has failed to process the snapshot. 
    • VSS writer 'Oracle VSS Writer - PROD' with class ID '26D02976-B909-43AD-AF7E-62A4F625E372' has failed to process the snapshot. 
    • VSS writer 'NTDS' with class ID 'B2014C9E-8711-4C5C-A5A9-3CF384484757' has failed to process the snapshot. 
    • etc

    Cause

    In most cases this is an issue with the software that VSS writer belongs to.

    Solution

    To investigate this issue, check whether issue with the writer reproduces without Acronis Cyber Protect. You can do this using Windows tool Diskshadow.

    Run the backup using Diskshadow tool to check the functionality of the VSS service components and the application VSS writers.

    (!) Diskshadow tool is available in Windows Server 2008 and later. If you use a version of Windows where Diskshadow is not available, proceed to Collect information, steps 2 and 3

    1. First, you need to restart the writers that might be in Failed state. Run Acronis VSS Doctor and start diagnostic. As a part of diagnostic process, VSS Doctor will restart the failed writers.

    2. Start the command prompt with elevated privileges:

    Start -> CMD -> Right click -> Run as Administrator

    3. Enter the Diskshadow tool interface:

    C:\Users\administrator> DISKSHADOW

    4. Specify that the shadow copies will persist across program exit, reset, or restart:

    DISKSHADOW> set context persistent

    5. Set the verbose output on:

    DISKSHADOW> set verbose on

    6. Start a full backup session:

    DISKSHADOW> begin backup

    7. Specify the volumes to be included in the backup, e.g.:

    DISKSHADOW> add volume C: alias VolumeC

    DISKSHADOW> add volume D: alias VolumeD

    8. Specify the writers that should be verified during the shadow copy creation: specify the ID of VSS writer(s) from the error message that you receive, e.g:

    DISKSHADOW> writer verify {5AFFB034-969F-4919-8875-88F830D0EF89}

    8.After you have specified all volumes and writers for backup, initiate the backup creation:

    DISKSHADOW> create

    Once shadow copy is created, terminate the backup process:

    DISKSHADOW> end backup

    Exit the Diskshadow tool:

    DISKSHADOW> exit

    During backup creation you will see following messages appearing in the command prompt, meaning that a particular component has been included into backup procedure and will be verified:

    * Writer "WMI Writer" is included:
    + Component is included: \WMI

    If one of the writers fails, you will see an error message similar to the following:

    ERROR: The selected writer "SqlServerWriter" is in a faulty state.
    - Status: 8 (VSS_WS_FAILED_AT_PREPARE_SNAPSHOT)
    - Writer Failure code: 0x (VSS_E_WRITERERROR_NONRETRYABLE)
    - Writer ID: {a65faa63-5ea8-4ebc-9dbd-a0c4db26912a}
    - Instance ID: {8c57ad9a-8055-49e0-96ec-d8b41ea327eb}

    Error on recent operation.
    - HRESULT (returned): 80042301
    - Error text: VSS_E_BAD_STATE

    If any writer fails with an error, you need to troubleshoot this writer and make sure it is functioning correctly before using VSS backup in Acronis Software. Collect the result of the backup with Diskshadow utility and contact the vendor responsible for the VSS writer that causes error.

    Some common VSS writers and the software they belong to are listed in the table below:

    VSS Writer Belongs to

    SystemWriter
    SqlServerWriter
    Microsoft Exchange Writer
    ASRWriter
    Dhcp Jet Writer

    In-box Windows VSS writers

    Microsoft

    Virtuozzo VSS Writer Virtuozzo
    Oracle VSS Writer Oracle

     

    If backup with Diskshadow does not produce any failures but Acronis backup still fails, collect the following information and contact Acronis Support for further troubleshooting:

    1) Result of backup with Diskshadow (as screenshots or output to file)

    2) VSS Doctor report

    3) System information - see article https://kb.acronis.com/acroinfo.

     

    Tags: