Symptom
Windows event log is spammed with error events with ID 10010 and "The server {1EF75F33-893B-4E8F-9655-C3D602BA4897} did not register with DCOM within the required timeout." message, if Acronis True Image is installed.
When looking into the details of the error events, ti_managers_proxy.dll is found
Cause
Known issue, which was partially fixed in build 17750 of Acronis True Image 2019.
Solution
If the issue persists after installing build 17750, you can disable the part in Acronis program that is responsible for generating these events. The cost would be that you will not be able to generate public links for files stored in Acronis Cloud synchronization folders from Windows Explorer. If you do not generate such links or do not use Acronis Cloud storage at all, you would not have any negative consequences at all.
To apply the solution:
- Run cmd as administrator (right-click on Command Prompt and select "Run as administrator" option) and execute the following command:
Windows 64-bit:
regsvr32 /u "C:\Program Files (x86)\Acronis\TrueImageHome\ti_managers_proxy.dll"Windows 32-bit:
regsvr32 /u "C:\Program Files\Acronis\TrueImageHome\ti_managers_proxy.dll" - Click OK in the pop-up message.
- Reboot the computer for changes to take effect and see, if Windows Explorer is fast once again.