61978: Acronis True Image 2019: Backup is shown as "Queued" when no other backups are running

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Operating Systems: 

Symptoms

Backup task status is displayed as "Queued" and never completes.

Cause

There are multiple possible causes:

1) Other backups are running in the same time, e.g. a long lasting initial full backup to Cloud (by-design behavior)

2) A known issue in the software that may sometimes occur if Survival Kit was created (known issue, fixed in Build 14610)

3) The option "Run missed operation when an external device is connected" was enabled for this particular backup task, the backup was missed one time, and since then the corresponding external disk still has not been connected yet (by-design behavior, not affecting other backup jobs)

4) Outdated or incorrect records in the program's database that occurred due to any other reason

Solution

After each step, check whether the issue is resolved:

1) Update to the latest build as described here

2) Check other backup tasks. If any other backup task is running - either wait till it finishes or stop/pause/suspend it

3) If the backup is supposed to go to an external drive, make sure the drive is connected

4) Update the destination's identifier in program's internal records:

  • Stop the backup task
  • Connect the external drive, if it is not connected yet
  • Open backup options: Schedule -> Advanced Settings and toggle the checkbox Run missed operation when an external device is connected
  • Click the Ok button
  • Open backup options: Schedule -> Advanced Settings and toggle the checkbox Run missed operation when an external device is connected again
  • Click Ok 

5) Reselect the backup destination:

  • Stop the backup task
  • Restart Acronis Scheduler2 Service:
    • Press Win+R and type services.msc in the Run window to open Services
    •  Find Acronis Scheduler2 Service in the list. Right-click on the service and select Restart
  • Click on the Backup destination tile and reselect the location for storing the backup
  • Click Ok to save changes

6) Recreate the scheduler database:

  • Stop the backup task
  • Restart Acronis Scheduler2 Service:
    • Press Win+R and type services.msc in the Run window to open Services
    •  Find Acronis Scheduler2 Service in the list. Right-click on the service and select Restart
  • Download Acronis Scheduler Manager, right-click it and select Run as administrator
  • Run the following command in Scheduler Manager:

    task zap

  • Edit backup tasks that need to be run automatically and redefine the schedule for them. Remember to click Ok to save changes for each backup task

7) Perform a clean reinstallation of the product as described in Acronis True Image: repair, update and clean installations on Windows. After reinstalling, you will need to set up new backup tasks.

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