Symptoms
- You rename a machine where Agent is installed, e.g. from Machine01 to Machine02
- After some time, name of the machine changes on Management Server
- When backup plan runs after machine is renamed, the name of backup archive contains old machine name. This applies both to existing backup plans and new backup plans created after the machine was renamed.
Cause
This is by design. During installation, Agent saves the machine name and uses the saved name for naming backup archives. Changing the saved machine name will create a new a new backup chain with new machine name.
There is no way to update existing archives' name with the new machine name.
Solution
If you want to start a new chain with new backup archive name, update the saved machine name in the system:
On Windows: saved machine name can be found in the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\BackupAndRecovery\Settings\CachedMachineName
On Mac:
/Library/Application Support/Acronis/Common/BackupAndRecovery.config
Change CachedMachineName parameter
On Linux:
/etc/Acronis/BackupAndRecovery.config
Change CachedMachineName parameter
After updating the saved machine name, restart Acronis Managed Machine Service.