Symptoms
You get the following error messages when attempting to use a backup location with deduplication as backup destination:
There is an error in the hash database
and
Database disk image is malformed
Cause
Deduplication database is corrupted, due to hardware issues with the storage or other reasons.
Solution
Rebuild the deduplication database by following the steps below:
- Delete the backup location from the list: connect to Management Console, go to Backups - > Locations, select the vault that produces errors and click Delete.
- Do one of the following:
- Click Backups > Add location, and then click Storage node.
- When creating a backup plan, click Where to back up > Add location, and then click Storage node.
- Click Settings > Storage nodes, select the storage node that will manage the location, and then click Add location.
- In Address field, select the storage node name or IP address that the agents will use to access the location.
- In Path field, enter the folder path or browse to the folder with backups. Click Done. Acronis Cyber Backup Management Server will fill in the settings from the backup location automatically
- Specify a new folder for Deduplication database.
This must be a folder on a hard drive local to the storage node. To improve the system performance, we recommend that you create the deduplication database and the managed location on different disks.
(!) Do not delete old deduplication database folder until the new deduplication database is created and proven to be working correctly. In case something goes wrong, you can re-add the backup location again, pointing to the old deduplication databases.
- Click Done to create the location.
- After this, the deduplication database will be rebuilt.
- After the backup location is added and backups are available for browsing, reattempt the backup.