61832: Acronis Cyber Protect Home Office, Acronis True Image: how to grant full disk access on macOS 10.14 Mojave or later

Last update: 27-09-2021

Symptoms

 

  1. Your Mac is running macOS Mojave (10.14) or more recent version
  2. Backups fail with the following error:

     Failed to enumerate directory 'Macintosh HD:/Library/Application Support/com.apple.TCC/'. It may be corrupted or does not exist.

    OR

    You receive the following message:

    Grant full disk access to Acronis True Image

Cause

Acronis Cyber Protect Home Office / Acronis True Image requires full disk access permissions in order to back up your data.

Full Disk Access is a new security feature introduced in macOS Mojave that requires some applications to be given full permission to access a user's protected files. Acronis software needs full disk access in order to protect your data as intended. If you choose not to give Full Disk Access, Acronis backup software will not be able to access your data on the disk and thus disk backup and backup of some files and folders will not be possible.

 

Solution

1. Open Security & Privacy

2. Click the "lock" button to allow changes

3. Drag the application icon from the window requesting to grant Full Disk Access to the Full Disk Access table.

(!) Please add Acronis True Image application exactly as it is shown on the picture: by dragging the icon from Acronis True Image prompt into the System Preferences window.

Adding Acronis True Image any other way will not work (e.g. by clicking the plus icon, or by dragging from the Applications list etc).

Builds before 17780 Build 17780

 

4. When you see a warning that Acronis True Image will not have a full disk access until it is quit, click Quit now

5. If you have followed the previous steps, you will see that two applications have been added:

com.acronis.trueimagehelper

Acronis True Image

It is correct and how it should be to work.

 

If you see only "Acronis True Image" in this list,

or

if you keep seeing the "Grant access" prompt at every Acronis True Image start up,

then most probably you have added it in a wrong way. In this case please remove it from the list by clicking on the minus button and then re-add as per instructions above, verify that both com.acronis.trueimagehelper and Acronis True Image have been added.

Click here to download a short screencast (1.27MB, 0 minutes 43 seconds) that illustrates how permissions are granted and the prompt disappears on the next Acronis True Image launch.