61714: Acronis Backup: backup fails with "VSS writer has timed out" or "The backup has failed because 'VSS Writer' has timed out during snapshot creation."

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Symptoms

Backup fails with:

VSS writer ... has timed out 

OR

The backup has failed because 'VSS Writer' has timed out during snapshot creation.

The error may involve different writers, see some of possible writers below:

  • Windows error: (0x800423F2) VSS writer 'System Writer' with class ID 'E8132975-6F93-4464-A53E-1050253AE220' has timed out. This may be caused by too intensive I/O on the machine at the backup start time. Try to re-schedule the backup to some different time. To troubleshoot VSS issues, download and run Acronis VSS Doctor available at https://www.acronis.com/en-us/personal/vss-diagnostic-free-tool/
  • Windows error: (0x800423F2) VSS writer 'ASR Writer' with class ID 'BE000CBE-11FE-4426-9C58-531AA6355FC4' has timed out. This may be caused by too intensive I/O on the machine at the backup start time. Try to re-schedule the backup to some different time. To troubleshoot VSS issues, download and run Acronis VSS Doctor available at https://www.acronis.com/en-us/personal/vss-diagnostic-free-tool/
  • Windows error: (0x800423F2) VSS writer 'Microsoft Hyper-V VSS Writer' with class ID '66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE' has timed out. This may be caused by too intensive I/O on the machine at the backup start time. Try to re-schedule the backup to some different time. To troubleshoot VSS issues, download and run Acronis VSS Doctor available at https://www.acronis.com/en-us/personal/vss-diagnostic-free-tool/ 

Cause

The issue is caused by too intensive workload on the machine at the backup start time.

A VSS writer is application-specific software that acts to ensure that application data is ready for shadow copy creation. Windows OS includes a set of VSS writers and VSS-aware applications install own VSS writers to the machine. If the workload on the machine is high at the backup time, a VSS writer might not respond in the expected timeframe, that is, reach a timeout. A backup made under these conditions might not be restorable, that is why Acronis software cancels this backup and shows this error message.

Solution

Try to reschedule the backup to a different time, for example, during non-business hours.

If you are backing up Hyper-V virtual machines and the Hyper-V host, we recommend scheduling these backups to different times.

If the error reproduces even when the workload on the machine is not high, run the backup using Diskshadow tool to check the functionality of the VSS service components and the application VSS writers.

1. Start the command prompt with elevated privileges:

Start -> CMD -> Right click -> Run as Administrator

2. Enter the Diskshadow tool interface:

C:\Users\administrator> DISKSHADOW

3. Specify that the shadow copies will persist across program exit, reset, or restart:

DISKSHADOW> set context persistent

4. Set the verbose output on:

DISKSHADOW> set verbose on

5. Start a full backup session:

DISKSHADOW> begin backup

6. Specify the volumes to be included in the backup, e.g.:

DISKSHADOW> add volume C: alias VolumeC

DISKSHADOW> add volume D: alias VolumeD

7. Specify the writers that should be verified during the shadow copy creation: specify the ID of VSS writer(s) from the error message that you receive, e.g for System Writer:

DISKSHADOW> writer verify {E8132975-6F93-4464-A53E-1050253AE220}

8.After you have specified all volumes and writers for backup, initiate the backup creation:

DISKSHADOW> create

Terminate the backup:

DISKSHADOW> end backup

Exit the Diskshadow tool:

DISKSHADOW> exit

During backup creation you will see following messages appearing in the command prompt, meaning that a particular component has been included into backup procedure and will be verified:

* Writer "System Writer" is included:
+ Component is included: \System Files

If one of the writers fails, you will see an error message similar to the following:

ERROR: The selected writer "SqlServerWriter" is in a faulty state.
- Status: 8 (VSS_WS_FAILED_AT_PREPARE_SNAPSHOT)
- Writer Failure code: 0x (VSS_E_WRITERERROR_NONRETRYABLE)
- Writer ID: {a65faa63-5ea8-4ebc-9dbd-a0c4db26912a}
- Instance ID: {8c57ad9a-8055-49e0-96ec-d8b41ea327eb}

Error on recent operation.
- HRESULT (returned): 80042301
- Error text: VSS_E_BAD_STATE

If any writer fails with an error, you need to troubleshoot this writer and make sure it is functioning correctly before using VSS backup in Acronis Software. 

If backup with Diskshadow does not produce any failures but Acronis backup still fails, collect the following information and contact Acronis Customer Central for further troubleshooting:

1) Result of backup with Diskshadow (as screenshots or output to file)

2) System information - see article https://kb.acronis.com/acroinfo

More information

To troubleshoot VSS issues, download and run Acronis VSS Doctor available at https://www.acronis.com/en-us/personal/vss-diagnostic-free-tool/

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