61689: Acronis Cyber Backup: warning during restore "A required privilege is not held by the client"

Last update: 30-04-2021

Symptoms

You restore files from a backup to a network share.

Restore finishes with a warning:

Windows error: (0x80070522) A required privilege is not held by the client
MODULE4
MESSAGESecurity error occurred while opening the file for writing.
Additional info:------------------------
Error code: 35
Module: 4
LineInfo: 0xA8A1022BD18AE000
Fields: {"$module":"disk_bundle_vsa64_6620"}
Message: Security error occurred while opening the file for writing.
------------------------
Error code: 10
Module: 4
LineInfo: 0xA8A1022BD18AE040
Fields: {"function":"CreateFileW","path":"\\\\?\\UNC\\file","$module":"disk_bundle_vsa64_6620"}
Message: Error occurred while creating the file.
------------------------
Error code: 65520
Module: 0
LineInfo: 0xBD28FDBD64EDB8F1
Fields: {"code":"2147943714","$module":"disk_bundle_vsa64_6620"}
Message: A required privilege is not held by the client

Cause

By default, the Restore Security Attributes option is enabled. While trying to open a file on the network share to modify security attributes, an 'access denied' error occurs. In that case, Acronis software opens the file without restoring security attributes. As a result, a warning is produced stating that security attributes were not restored.

Solution

To avoid warnings restore without enabling the Restore Security Attributes option.