Install the latest build or fix the path to the database
Symptoms
- You use Acronis Cyber Backup 12.5 Update 3 (Build 10130)
- You run an application-aware backup of a disk with MS SQL database
- You receive a warning similar to the following one:
Database name: 'MyDatabase01'
Database logical file name: 'MyDatabase01'
Incorrect value: 'c:\Program Files\Microsoft SQL Server\MSSQL10_50.SQLEXPRESS\\MyDatabase01_SQLEXPRESS.mdf'
Error: A double slash in the path.
To remove the double slash, run the T-SQL command: ALTER DATABASE MODIFY FILEand the following error in logs:
Error code: 5900
Module: 87
LineInfo: 0x33884DBD64365311
Fields: {"$module":"ArsAgentProvider_vsa64_10330","IsReturnCode":"1"}
Message: Problems detected that may cause a VSS snapshot failure.
(!) This article applies only to the case when you receive both the error and the warning specified above.
Cause
Acronis Cyber Backup products check the database paths before backup to ensure snapshot consistency.
If the path to the database contains a double slash or an extra space at the end, the snapshot creation will fail.
Solution
Acronis Cyber Backup 12.5: this issue has been fixed in Update 3.2 (Build 11010). Please update to the latest build: see this article for instructions
More information
To work around the issue without installing the latest build: use the following workaround to fix the issue with database path:
1. Open SQL Server Management Studio (make sure that SSMS version matches the version of SQL instance running on the machine)
2. Run the following query to get the list of database names and locations:
USE <database_name>
SELECT * FROM sys.database_files
3. In the output, find the database that is mentioned in the warning
4. Run the following command to modify physical path to the file:
ALTER DATABASE <database name>
MODIFY FILE (NAME = '<logical name>', FILENAME='<path to file>');
where
<database name> is the name of the database that is mentioned in the error, no changes needed
<logical name> is the logical name of the file mentioned in the error, no changes needed
<path to file> is the full path to the file that is mentioned in the error, without double slashes or extra spaces at the end
More information
Acronis Development Team is working on fixing the issue with backing up databases with double slashes in the path.