Symptoms
1. Installation of Acronis True Image over an earlier version/build fails with "Fatal error during installation"
2. MSI log refers a missing .MSI file in a subfolder of C:\Windows just before "Return value 3" with an error
The system cannot find the file specified
Example of installation log:
Cause
Acronis True Image was installed previously, or there were attempts to install it. Then, a third-party software for "tuneup", "optimization" and "cleanup" purposes deleted .MSI file of Acronis. During installation, Acronis True Image requires that old .MSI file to perform the necessary actions to install version, but is unable to find the deleted .MSI
Solution
Method 1. Delete a registry key
-
- Open Windows Start menu
- Type regedit and press Enter on keyboard
- Click Yes to confirm launching the program
- Navigate to the key HKEY_CLASSES_ROOT\Installer\UpgradeCodes\8146D9A0B8A6C404BB633071DEDE4E59
- Right click 8146D9A0B8A6C404BB633071DEDE4E59 in the folder tree on the left side of the window and select Delete
- Click Yes to confirm the operation
- Reattempt the installation of Acronis True Image
Method 2. Perform a clean installation
- Run Acronis Cleanup Utility to remove traces of previous installations: see this article for instructions
- Apply Microsoft FixIt tool
- Reattempt the installation
If the problems persists, collect the following information and contact Acronis Support:
1. Screenshot of the error
2. New MSI log collected after applying the solution
3. Process Monitor log of the installation process: see this article for instructions
4. System Report: see this article for instructions