60929: Acronis Backup: recovery of mailboxes fails with "The account does not have permission to impersonate the requested user"

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Symptoms

You are recovering Exchange data: mailboxes or emails.

Recovery fails with:

Error code: 3
Module: 349
LineInfo: 0x5B3CC972C81BD710
Fields: {"$module":"arx_agent_fork_vsa64_9058"}
Message: The account does not have permission to impersonate the requested user.

Error code: 3126
Module: 91
LineInfo: 0x5B3CC972C81BD701
Fields: {"$module":"arx_agent_vsa64_8477"}
Message: SOAP protocol error has occurred while accessing the EWS server. SOAP code: ErrorImpersonateUserDenied. SOAP message: The account does not have permission to impersonate the requested user.

Cause

The user accessing the Exchange databases is not a member of the Organization Management role group and does not have sufficient priviliges to restore individaul mailboxes or emails.

Solution

To allow this user to restore mailboxes or emails, configure impresonation for this user:

  1. Open the Exchange Management Shell. From the Start menu, choose All Programs > Microsoft Exchange Server.
  2. Run the New-ManagementRoleAssignment cmdlet to add the impersonation permission to the specified user. The following example shows how to configure impersonation to enable a service account to impersonate all other users in an organization.
     
    New-ManagementRoleAssignment –name:impersonationAssignmentName –Role:ApplicationImpersonation –User:<user>
     
    where <user> is the user you have specified to access Exchange databases

Re-attempt recovery.

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