60926: Acronis Cyber Protect Cloud, Acronis Cyber Backup: recovery of mailboxes fails with "Insufficient rights for PowerShell command execution 'Get-User'"

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Last update: 30-04-2021

Symptoms

You are restoring an Exchange mailbox. The original mailbox does not exist anymore and should be recreated during recovery.

Recovery fails with:
Error code: 397
Module: 91
LineInfo: 0x8BF116F82F62BBEF
Fields: {"$module":"arx_agent_fork_vsa64_6200"}
Message: Nothing to recover. For the details, see the log. Last error:
------------------------
Error code: 145
Module: 91
LineInfo: 0x8BF116F82F62BADF
Fields: {"$module":"arx_agent_fork_vsa64_6200"}
Message: Insufficient rights for PowerShell command execution 'Get-User'

Cause

The user performig the recovery does not have sufficient privileges to recreate mailboxes.

Solution

Add the user to the Recipient Management role group:

  1. On the Exchange server (or on a workstation that has the Exchange System Management Tools installed), open Active Directory Users and Computers snap-in: click Start -> in Search, type dsa.msc and press Enter. Or click Start, point to All Programs, point to Microsoft Exchange, and then click Active Directory Users and Computers.
  2. Expand the <domain>.com tree and navigate to Microsoft Exchange Security Groups.
  3. Right-click the Recipient Management group and select Properties.
  4. Switch to the Members tab, click Add, find the user, which you have specified in the Specify credentials window while accessing the Exchange database in the Databases tab, and add this user to the group.
  5. Click Apply.

For Microsoft Exchange 2013 and 2016, you can also use this method:

  1. In the Exchange Administration Center, navigate to Permissions -> Admin Roles.
  2. Select the Recipient Management role group, and then click the Edit (pencil) icon.
  3. In the Members section, click the Add (+) icon.
  4. Select the user, which you have specified in the Specify credentials window while accessing the Exchange database in the Databases tab, click Add, and then click OK.
  5. Click Save to save the changes to the role group.

Re-attempt recovery.