Symptoms
You are backing up a VMware vCenter environment with Acronis Backup.
You have upgraded from Acronis Backup 11.7 to Acronis Backup 12.5.
After upgrade, you cannot open the web console (the page stays blank) and Acronis Management Server Service does not start.
In logs, you see this error:
Error 0xb9000a: Failed to initialize server.
| trace level: error
| line: 0xb957662f70a232d
| file: k:\7048\enterprise\service\impl\server.cpp:420
| function: Core::ServerImpl::Start
| $module: management_server_vsa64_7048
|
| error 0xb9000a: Failed to initialize server.
| line: 0xb957662f70a24b7
| file: k:\7048\enterprise\service\impl\server.cpp:814
| function: Core::ServerImpl::Initialize
| $module: management_server_vsa64_7048
|
| error 0xb90010: Failed to start component 'VMwareManager'.
| line: 0x27fbb047d6ce05a3
| file: k:\7048\enterprise\service\impl\component_manager_impl.cpp:126
| function: Core::ComponentManager::Record::Start
| $module: management_server_vsa64_7048
|
| error 0xe08006: Failed to enumerate the registered VMware vCenters.
| line: 0xa20120e20d7da2a2
| file: k:\7048\enterprise\migration\vm_backup\virtual_center\managers\vmware_vcenter\impl\manager_impl.cpp:1375
| function: `anonymous-namespace'::ManagerImpl::GetServers
| $module: virtual_center_addon_vsa64_7048
|
| error 0x2760003: Cannot get access to the user profile.
| line: 0xa20120e20d7da704
| file: k:\7048\enterprise\migration\vm_backup\virtual_center\managers\vmware_vcenter\impl\manager_impl.cpp:2497
| function: `anonymous-namespace'::ManagerImpl::ResolveCredentials
| $module: virtual_center_addon_vsa64_7048
|
| error 0x273000d: Access violation in module 'virtual_center_addon.dll' at line '0xa20120e20d7da704', executable: 'ManagementServer.exe'.
| line: 0xe839411589f18b6e
| file: k:\7048\enterprise\managers\access\impl\profile_vault_component.cpp:1589
| function: AccessManagement::ProfileVaultComponent::LookupCredentialsInSystemProfile
| $module: access_manager_vsa64_7048
|
| error 0x273001c: Account spec for lookup is not valid.
| line: 0xe839411589f1879b
| file: k:\7048\enterprise\managers\access\impl\profile_vault_component.cpp:610
| function: AccessManagement::ProfileVaultComponent::VerifyLookupRequest
| $module: access_manager_vsa64_7048
Cause
Issue with upgrading the registry key holding the vCenter credentials.
Solution
Acronis development team is working on the issue.
As workaround:
- On the machine with Acronis Management Server installed, open Windows Registry: Start -> in search, type regedit.exe and press Enter.
- Navigate to HKEY_LOCAL_MACHINE\Software\Acronis\AMS\Configuration\Virtual\EsxRegistry\VCenters.
- Export and then delete the VCenters key.
- Start Acronis Management Server service: Start -> in search, type services.msc and press Enter -> locate Acronis Management Server service and click Start service.
- Re-register the Agent for VMware (for guidelines, see this article).