60667: Acronis Backup 12.5: backup fails with "Failed to add account in user profile"

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Applies to: 

Symptoms

Backup operation or applying a backup plan to a machine fails with:

Windows Error: (0x80070002) The system cannot find the file specified
0x2730016: Failed to add account in user profile.

Carefully check the full error stack for one of these errors:

Error 1

| error 0x40011: The specified file does not exist.
| line: 0xf35f747b3b21f916
| file: k:\7641\core\file\windows\winnt_dir.cpp:525
| function: winnt_dir::OpenFile
| function: OpenFileW
| path: \\?\C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\profiles\DEC92E32-D7CA-2543-24C7-0E8FF122F62F\lock
| $module: access_manager_vsa64_7641

Error 2

| error 0x25e000b: Cannot open file.
| line: 0x2a0cf3e48ece3369
| file: k:\7048\enterprise\common\file_utils\source\file_io.cpp:46
| function: FileUtils::OpenFileI
| path: C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\config\preferred
| $module: access_manager_vsa64_7048

or

| error 0x25e000b: Cannot open file.
| line: 0x2a0cf3e48ece3369
| file: k:\7048\enterprise\common\file_utils\source\file_io.cpp:46
| function: FileUtils::OpenFileI
| path: C:\ProgramData\Acronis\AMS\AccessVault\config\preferred
| $module: access_manager_vsa64_7048

If you have found one of these errors, follow this article. Otherwise, contact Acronis Customer Central.

Solution for error 1

Cause

You have reinstalled Acronis Backup on this machine or have deleted the machine from the management server and added it back. As a result, duplicate user profiles are created.

Solution

The mechanism will be reworked in the next updates of Acronis Backup 12.5

Meanwhile, delete the duplicate profile manually:

  1. Note the profile specified in the error message (in the example above: DEC92E32-D7CA-2543-24C7-0E8FF122F62F).
  2. On the affected machine, open C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\profiles\
  3. In this folder, you will find 2 profiles: the one specified in the error message and another one. Note the GUID of the other one.
  4. Stop Acronis Managed Machine Service: open Command Prompt and issue:
    net stop mms
  5. Download SQLite.
  6. In Command Prompt, navigate to the folder where you have saved SQLite. Use the cd command.
  7. Issue this command:
    sqlite3.exe C:\ProgramData\Acronis\BackupAndRecovery\MMS\AccessVault\config\profiles.db3
  8. Issue this command:
    delete from PROFILES where ID='<GUID>';
    where <GUID> is the GUID you have noted in step 3.
  9. Press Ctrl+Z to exit SQLite.
  10. Start Acronis Managed Machine Service:
    net start mms

Solution for error 2

Cause

Issue with update from previous versions.

Solution

To receive fix for the issue, please contact Acronis Customer Central with reference to this article.

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