Symptoms
Backup, recovery, or replication of a VMware virtual machine fails with:
VMware_VDDK: [NFC ERROR] NfcNewAuthdConnectionEx: Failed to connect to peer. Error: Failed to connect to server
and
in version 11.7:
Error code: 14009
Module: 0
LineInfo: c61573f663f5d75d
Fields: $module : esx_srv_glx_pic_44190
Message: NBD_ERR_NETWORK_CONNECT
in version 12.5:
LineInfo: 0xc61573f663f5d7ca
Error 0xd: You do not have access rights to this file
Cause
Thie error indicates an incorrect network setup: the Virtual Appliance cannot connect to the ESX(i) host using its registration name obtained from vCenter.
You can check it this way:
- Note the hostname or the IP address specified in the error message.
- Open vSphere client and establish connection to an ESX(i) host or vCenter.
- Navigate to the Virtual Appliance and open the Console tab:
In Acronis Cyber Backup 12.5: Ctrl+Alt+F2
In Acronis Cyber Backup 11.7: Ctrl+Shift+Alt+Space+F2 - Ping ESX host or vCenter:
ping hostname_of_ESX
or
ping IP_of_ESX
The ping command will not be successful, if you have a DNS issue.
To exit the console, press Alt+F1.
Solution
- Make sure the Virtual Appliance is in the correct subnet. To check and change network settings, open Virtual Appliance console in vSphere client.
- Make sure the required ports are open. Check your firewall settings on the ESXi host. Acronis Cyber Backup Agent for VMware (both Virtual Appliance and Windows agent) require successful connection to standard TCP port 902 on ESXi host.
If you cannot locate and resolve the issue, you can specify the IP of the ESX(i) in Virtual Appliance hosts file as workaround:
- To open Virtual Appliance's console, press:
In Acronis Cyber Backup 12.5: Ctrl+Alt+F2
In Acronis Cyber Backup 11.7: Ctrl+Shift+Alt+Space+F2 - To open the hosts file, issue:
vi /etc/hosts - To enter the editing mode, press the "O" key.
- Write the IP address and the name of the management server:
XXX.XXX.XXX.XXX hostname - To save changes, press Escape and type:
:x - Press Enter.
- To exit the console, press Alt+F1.
Retry the operation. It should run successfully now.
More information
See also: