Introduction
Sometimes during certain operations with vCDA Web Interface you may receive errors similar to the ones below:
Cause
Acronis vCloud Director Administrator appliance uses Acronis command line tool (acrocmd) to communicate with Acronis Management Server. It obtains data from sending acrocmd requests to the management server database and transforms the reply into human-readable form - vCDA Web Interface items. There are default timeout values for acrocmd calls set under the vCDA PHP server's configuration files. In case a request exceeds the maximum memory limit or the time frame allocated, it times out. As a result, you see one of the errors above.
This mechanism is going to be reworked in future versions of Acronis Backup Advanced for vCloud.
For better understanding of Acronis Backup Advanced for vCloud's architecture you may refer to this arcticle.
Solutions
- In most of the cases major performance degradations are detected when you are logged in to vCDA as vCD Administrator. In this case vCDA is gathering statistics for ALL vCD Organizations which takes much time and results in timeouts. This can be avoided by logging in as vCD Organization's administrator. This way the product won't have to load data for all existing Organizations, but only for the one this user administer.
- Increase request timeouts in PHP settings on vCDA. There are 2 parameters for terminating a session while loading data. One of them limits the maximum memory a request can occupy, the other one limits the maximum time frame allocated for a request. To change them, proceed according to instructions below:
- Log in to vCDA's Command Line Interface.
- Open /opt/acronis/vcd-agent/app/config.php
- Find the following parameters:
// Memory limit in Mb.
define('MEMORY_LIMIT', '256M'); <=== maximum memory allocated for the request
// Max execution time
define('MAX_EXECUTION_TIME', 600); // 10 min <=== request timeout time. - Increase these values, and then save the changes.
- Restart vCDA's PHP server.